HP OpenVMS Systems

Content starts here

Readme for HP Performance Agent (OVPA) Version 4.0-40 for OpenVMS

This readme provides information on how to install the HP Performance Agent (OVPA) kit on the OpenVMS operating system and cluster. This readme file includes the following sections:

     Verifying the prerequisites on an OpenVMS System

     Installing the HP Performance Agent (OVPA) Kit on the OpenVMS System


Verifying the prerequisites on an OpenVMS System

OpenVMS Patches

Before installing the HP Performance Agent (OVPA) kit on the OpenVMS operating system, you have to verify that the following OpenVMS patches and software have been installed on the system:

Ensure that the following OpenVMS patches are applied:

For OpenVMS Alpha:

  • OpenVMS Alpha Version 7.3-2

    • VMS732_SYS V8.0 or later

    • VMS732_UPDATE V6.0 or later

  • OpenVMS Alpha Version 8.2

    • VMS82A_UPDATE V7.0 or later

    •  VMS82A_SYS V7.0 or later

  • OpenVMS Alpha Version 8.3

    • VMS83A_UPDATE V3.0 or later

  • OpenVMS Alpha Version 8.4

    For OpenVMS Integrity servers:

  • OpenVMS Integrity servers Version 8.2-1

    • VMS821I_UPDATE V5.0 or later

    • HP I64VMS VMS821I_ICXXL V5.0 or later

  • OpenVMS Integrity servers Version 8.3

    • VMS83I_UPDATE V1.0 or later

    • VMS83I_SYS V1.0 or later

    • HP I64VMS VMS83I_ICXXL V5.0 or later

  • OpenVMS Integrity servers Version 8.3-1H1

    • HP I64VMS VMS831H1I_ICXXL V2.0 or later

  • OpenVMS Integrity servers Version 8.4

    The patches are available at the HP ITRC web address:
    http://www2.itrc.hp.com/service/patch/mainPage.do

     TCP/IP Services for OpenVMS

The PORTMAPPER service must be started for OVPA components to function accurately.

OVPA will NOT work with third party IP products. The OVPA software links with the HP TCP/IP network product and therefore requires the HP TCP/IP product to run.
 

      The Performance Data Collector for OpenVMS

You must have the Performance Data Collector (TDC) Version 2.3-15 or 2.3-20 installed on your OpenVMS system for OVPA to collect data.

The complete TDC kit is included with the kit you downloaded from the web. Install only the run-time part of TDC for each version of OpenVMS that you want to run with OVPA.

The latest kit can also be obtained from:
http://www.hp.com/products/openvms/tdc/
 

Installing the HP Performance Agent (OVPA) Kit on the OpenVMS System

To install the OVPA kit for OpenVMS, follow these steps:

  1. To extract the PCSI kit, run OVPA-x0400-xx-AXP.EXE (for Alpha) or OVPA-x0400-xx-I64.EXE (for Integrity servers) by entering the following commands:

    For OpenVMS Alpha:

$ RUN OVPA-x0400-xx-AXP.EXE
HP-AXPVMS-OVPA-x0400-xx-1.PCSI$COMPRESSED
HP-AXPVMS-OVPA-x0400-xx-1.PCSI$COMPRESSED_ESW
HP-AXPVMS-OVPA-x0400-xx-1.PCSI$COMPRESSED_HPC


For OpenVMS Integrity servers:

$ RUN OVPA-x0400-xx-I64.EXE
HP-I64VMS-OVPA-x0400-xx-1.PCSI$COMPRESSED
HP-I64VMS-OVPA-x0400-xx-1.PCSI$COMPRESSED_ESW
HP-I64VMS-OVPA-x0400-xx-1.PCSI$COMPRESSED_HPC

  1. HP recommends that you copy the kit and corresponding manifest file to the SYS$UPDATE: directory.

    1. Log into the OpenVMS system using the SYSTEM account.

    2. Set the default directory to SYS$UPDATE:

      $ SET DEFAULT SYS$UPDATE

    3. Use the PRODUCT INSTALL command to install the kit:

      $ PRODUCT INSTALL OVPA  
       

  2. If you are installing on OpenVMS node where OVO HTTPS Agents are installed:

  1. Configure OVO HTTPS Agents communication port to any port other than 383. For more information, see the "Restrictions and Known Issues" in the Release notes.
     

  2. Run SYS$STARTUP:OVO8_OVPA$CONFIG.COM.

  1. Start OVPA Agents.

To start OVPA, log into the OpenVMS system using the SYSTEM account and enter the following command:

$ @SYS$STARTUP:OVPA$STARTUP

Note: This startup command procedure starts SSL and TDC, which are both required for OVPA to function.